Android | Android requires .class compatibility ..

Written by Super User. Posted in Android Problemler

Workspace'inizden bir projenizi import ediyorsunuz ve çalıştığını bildiğiniz projenizde bir çok hata yer aldığını görüyorsunuz. Hata olarak ise , "Android requires .class compatibility set to 5.0. Please fix project properties." cümlesini görüyorsunuz. Bu hatayla ilgili olarak;

Bu hata Java derleyicisinin seviyesi ile ilgili bir hatadır. Properties > Java Compiler > JDK compliance altındaki, "compiler compliance level" seçeneğini projenize uygun şekilde düzeltiniz. Sonrasında, arkanıza yaslanıp önceden hata veren kısımların nasıl düzeldiğini gözlemleyiniz. :)